Don’t panic while error.

Here is what happened and i did panic while answering the blog’s like this…

READ THE ERROR MESSAGE VERY CAREFULLY WITH SOUND MIND.

DO NOT PANIC.

Scenario : Upgrading from 2008R2 Sp2 Standard Edition to 2014 Sp1 Standard CU11.

Error :

“The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program”

i kind trimmed the error message cause this blog page wont be enough..,

 

Cause :  This error might occurred while upgrading directly using recommended options in the setup path , and also this error occurs when trying to apply SP1 along with 2014 Binaries which kind of combined download.

SO AVOID USING THE BINARIES WITH SQL SERVER 2014 +SP1.

Do them individually SQL Server 2014 install and then SP1 and then CU’s any. Same thing follows with SP2.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s